• Ben Hutchings's avatar
    Import Debian changes 5.2.7-1 · e20cba76
    Ben Hutchings authored and Lorenzo "Palinuro" Faletra's avatar Lorenzo "Palinuro" Faletra committed
    linux (5.2.7-1) unstable; urgency=medium
    
      * New upstream stable update:
        https://www.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.2.7
        - [armhf] dts: rockchip: Make rk3288-veyron-minnie run at hs200
        - [armhf] dts: rockchip: Make rk3288-veyron-mickey's emmc work again
        - [arm64] clk: meson: mpll: properly handle spread spectrum
        - [armhf] dts: rockchip: Mark that the rk3288 timer might stop in suspend
        - ftrace: Enable trampoline when rec count returns back to one
        - [arm64] dts: qcom: qcs404-evb: fix l3 min voltage
        - [arm64] dts: marvell: mcbin: enlarge PCI memory window
        - [armhf,arm64] dmaengine: tegra-apb: Error out if DMA_PREP_INTERRUPT flag
          is unset
        - [arm64] dts: rockchip: fix isp iommu clocks and power domain
        - kernel/module.c: Only return -EEXIST for modules that have finished
          loading
        - PCI: OF: Initialize dev->fwnode appropriately
        - [armhf,arm64] firmware/psci: psci_checker: Park kthreads before stopping
          them
        - [arm64] qcom: qcs404: Add reset-cells to GCC node
        - swiotlb: fix phys_addr_t overflow warning
        - [arm64] clk: tegra210: fix PLLU and PLLU_OUT1
        - fs/adfs: super: fix use-after-free bug
        - [arm64] dts: rockchip: Fix USB3 Type-C on rk3399-sapphire
        - btrfs: tree-checker: Check if the file extent end overflows
        - btrfs: fix minimum number of chunk errors for DUP
        - btrfs: Flush before reflinking any extent to prevent NOCOW write falling
          back to COW without data reservation
        - [arm64] remoteproc: copy parent dma_pfn_offset for vdev
        - btrfs: qgroup: Don't hold qgroup_ioctl_lock in btrfs_qgroup_inherit()
        - cifs: Fix a race condition with cifs_echo_request
        - ceph: fix improper use of smp_mb__before_atomic()
        - ceph: fix dir_lease_is_valid()
        - ceph: return -ERANGE if virtual xattr value didn't fit in buffer
        - virtio-mmio: add error check for platform_get_irq
        - drm/amd/display: Expose audio inst from DC to DM
        - cifs: fix crash in cifs_dfs_do_automount
        - perf version: Fix segfault due to missing OPT_END()
        - [x86] kvm: avoid constant-conversion warning
        - ACPI: fix false-positive -Wuninitialized warning
        - [x86] KVM: nVMX: Ignore segment base for VMX memory operand when segment
          not FS or GS
        - bpf: fix BTF verifier size resolution logic
        - be2net: Signal that the device cannot transmit during reconfiguration
        - mm/z3fold: don't try to use buddy slots after free
        - mm/memcontrol.c: keep local VM counters in sync with the hierarchical ones
        - mm/z3fold.c: reinitialize zhdr structs after migration
        - [x86] apic: Silence -Wtype-limits compiler warnings
        - [arm*] mm/cma.c: fail if fixed declaration can't be honored
        - mm/ioremap: check virtual address alignment while creating huge mappings
        - coda: add error handling for fget
        - uapi linux/coda_psdev.h: move upc_req definition from uapi to kernel side
          headers
        - ipc/mqueue.c: only perform resource calculation if user valid
        - device-dax: fix memory and resource leak if hotplug fails
        - mm/hotplug: make remove_memory() interface usable
        - stacktrace: Force USER_DS for stack_trace_save_user()
        - [x86] crypto: ccp - Fix SEV_VERSION_GREATER_OR_EQUAL
        - xen/pv: Fix a boot up hang revealed by int3 self test
        - [x86] kvm: Don't call kvm_spurious_fault() from .fixup
        - [x86] paravirt: Fix callee-saved function ELF sizes
        - [x86] boot: Remove multiple copy of static function sanitize_boot_params()
        - bpf: Disable GCC -fgcse optimization for ___bpf_prog_run()
        - drm/nouveau: fix memory leak in nouveau_conn_reset()
        - drm/nouveau/dmem: missing mutex_lock in error path
        - kconfig: Clear "written" flag to avoid data loss
        - tpm: Fix null pointer dereference on chip register error path
        - Btrfs: fix incremental send failure after deduplication
        - Btrfs: fix race leading to fs corruption after transaction abort
        - dax: Fix missed wakeup in put_unlocked_entry()
        - fgraph: Remove redundant ftrace_graph_notrace_addr() test
        - [armhf,arm64] mmc: dw_mmc: Fix occasional hang after tuning on eMMC
        - [armhf] mmc: meson-mx-sdio: Fix misuse of GENMASK macro
        - mmc: mmc_spi: Enable stable writes
        - gpiolib: Preserve desc->flags when setting state
        - gpio: don't WARN() on NULL descs if gpiolib is disabled
        - gpiolib: fix incorrect IRQ requesting of an active-low lineevent
        - IB/hfi1: Fix Spectre v1 vulnerability
        - drm/nouveau: Only release VCPI slots on mode changes
        - mtd: rawnand: micron: handle on-die "ECC-off" devices correctly
        - eeprom: at24: make spd world-readable again
        - [arm*] i2c: iproc: Fix i2c master read more than 63 bytes
        - selinux: fix memory leak in policydb_init()
        - [x86] ALSA: hda: Fix 1-minute detection delay when i915 module is not
          available (see #931507)
        - mm: vmscan: check if mem cgroup is disabled or not before calling memcg
          slab shrinker
        - mm: migrate: fix reference check race between __find_get_block() and
          migration
        - mm: compaction: avoid 100% CPU usage during compaction when a task is
          killed
        - mm/migrate.c: initialize pud_entry in migrate_vma()
        - loop: Fix mount(2) failure due to race with LOOP_SET_FD
        - [s390x] dasd: fix endless loop after read unit address configuration
        - cgroup: kselftest: relax fs_spec checks
        - [hppa] Add archclean Makefile target
        - [hppa] Strip debug info from kernel before creating compressed vmlinuz
        - [hppa] Fix build of compressed kernel even with debug enabled
        - drivers/perf: arm_pmu: Fix failure path in PM notifier
        - [arm64] compat: Allow single-byte watchpoints on all addresses
        - [arm64] cpufeature: Fix feature comparison for CTR_EL0.{CWG,ERG}
        - io_uring: fix KASAN use after free in io_sq_wq_submit_work
        - scsi: mpt3sas: Use 63-bit DMA addressing on SAS35 HBA
        - nbd: replace kill_bdev() with __invalidate_device() again
        - xen/swiotlb: fix condition for calling xen_destroy_contiguous_region()
        - xen/gntdev.c: Replace vm_map_pages() with vm_map_pages_zero()
        - RDMA/devices: Do not deadlock during client removal
        - IB/mlx5: Fix unreg_umr to ignore the mkey state
        - IB/mlx5: Use direct mkey destroy command upon UMR unreg failure
        - IB/mlx5: Move MRs to a kernel PD when freeing them to the MR cache
        - IB/mlx5: Fix clean_mr() to work in the expected order
        - IB/mlx5: Fix RSS Toeplitz setup to be aligned with the HW specification
        - IB/hfi1: Check for error on call to alloc_rsm_map_table
        - IB/hfi1: Drop all TID RDMA READ RESP packets after r_next_psn
        - IB/hfi1: Field not zero-ed when allocating TID flow memory
        - [x86] drm/i915/perf: fix ICL perf register offsets
        - [x86] drm/i915/gvt: fix incorrect cache entry for guest page mapping
        - [x86] cpufeatures: Carve out CQM features retrieval
        - [x86] cpufeatures: Combine word 11 and 12 into a new scattered features
          word
        - [x86] speculation: Prepare entry code for Spectre v1 swapgs mitigations
        - [x86] speculation: Enable Spectre v1 swapgs mitigations (CVE-2019-1125)
        - [amd64] entry: Use JMP instead of JMPQ
        - [x86] speculation/swapgs: Exclude ATOMs from speculation through SWAPGS
        - Documentation: Add swapgs description to the Spectre v1 documentation
    
      [ Ben Hutchings ]
      * [armhf] udeb: Remove davinci_cpdma from nic-modules (fixes FTBFS)
      * Bump ABI to 2
      * [armel/marvell] Increase maximum image size (fixes FTBFS):
        - This removes support for QNAP TS-109, TS-119, TS-209, TS-219, TS-409,
          and HP Media Vault mv2120
        - This may be reverted if we can disable or modularise some features
    
      [ Julien Cristau ]
      * Fix libcpupower-dev's Depends field to account for SONAME bump.
    
    linux (5.2.6-1) unstable; urgency=medium
    
      * New upstream release:
        https://kernelnewbies.org/Linux_5.1
        https://kernelnewbies.org/Linux_5.2
    
      * New upstream stable update:
        https://www.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.2.1
        https://www.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.2.2
        https://www.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.2.3
        https://www.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.2.4
        https://www.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.2.5
        https://www.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.2.6
    
      [ Bastian Germann ]
      * [armhf] Enable C_CAN as a module. (Closes: #929968)
    
      [ Ben Hutchings ]
      * Drop "x86/boot: Add ACPI RSDP address to setup_header", which should
        not have been applied to 4.20 or later
      * Drop redundant part of "Install perf scripts non-executable"
      * Drop "kbuild: Use -nostdinc in compile tests", which is no longer needed
      * debian/rules.d/scripts/kconfig: Update for upstream file renaming
      * debian/rules.d/scripts/mod: Add uuid_t and UUID_STRING_LEN definitions
      * liblockdep: Disable until it can be built again
      * libcpupower: Bump soversion since 2 exported functions have been removed
      * libbpf: Stop overriding upstream soname; rename shlib package to libbpf0
      * vfs: Enable FS_ENCRYPTION as built-in; disable on armel/marvell
      * net: Enable NET_DEVLINK as built-in; disable on armel/marvell
      * aufs: Update support patchset to aufs5.2 20190805
      * lockdown: Update for 5.2:
        - Update "acpi: Ignore acpi_rsdp kernel param when the kernel ..."
        - Add "tracefs: Restrict tracefs when the kernel is locked down"
        - Add "efi: Restrict efivar_ssdt_load when the kernel is locked down"
        - Drop "MODSIGN: Import certificates from UEFI Secure Boot"
      * [rt] Rebase onto 5.2.6, and re-enable
      * [armhf,arm64] gpu: Enable DRM_LIMA, DRM_PANFROST as modules
      * sched: Enable PSI (Closes: #931247)
      * [armhf,arm64] power: Enable ENERGY_MODEL
      * [armhf,arm64] cpufreq: Enable CPU_FREQ_DEFAULT_GOV_SCHEDUTIL (instead of
        CPU_FREQ_DEFAULT_GOV_PERFORMANCE)
      * hamradio: Disable auto-loading as mitigation against local exploits
      * hamradio: Enable most options in top-level config:
        - [arm64,ia64,mips*,riscv64,s390x,sh4,sparc64] Enable AX25, NETROM, ROSE,
          and all possible drivers (Closes: #920651)
        - [alpha,amd64,armel] ax25: Enable AX25_DAMA_SLAVE
        - [armhf] Enable BPQETHER, BAYCOM_SER_FDX, BAYCOM_SER_HDX, BAYCOM_PAR,
          BAYCOM_EPP, YAM as modules
      * [armel/rpi,armhf] media: Enable VIDEO_BCM2835 as module
      * usb/typec: Enable TYPEC_DP_ALTMODE, TYPEC_NVIDIA_ALTMODE as modules
        (Closes: #931752)
      * [amd64/cloud-amd64] hwrandom: Enable HW_RANDOM_VIRTIO (Closes: #914511)
      * [ppc64*] crypto: Enable CRYPTO_DEV_NX, and CRYPTO_DEV_NX_ENCRYPT,
        CRYPTO_DEV_NX_COMPRESS, CRYPTO_DEV_NX_COMPRESS_PSERIES,
        CRYPTO_DEV_NX_COMPRESS_POWERNV as modules (Closes: #931374)
      * [ppc64*] Disable PPC_TRANSACTIONAL_MEM (Closes: #866122)
    
      [ Vagrant Cascadian ]
      * [arm64] Enable modules to support audio on pinebook: SND_SUN4I_I2S,
        SND_SUN8I_CODEC, SND_SUN50I_CODEC_ANALOG, SND_SIMPLE_CARD,
        SND_SOC_SIMPLE_AMPLIFIER. (Closes: #921019)
    
      [ Romain Perier ]
      * Refreshed patches:
        - debian/revert-objtool-fix-config_stack_validation-y-warning.patch
        - debian/dfsg/video-remove-nvidiafb-and-rivafb.patch
        - debian/gitignore.patch
        - debian/mips-disable-werror.patch
        - bugfix/all/firmware-remove-redundant-log-messages-from-drivers.patch
        - bugfix/arm/arm-mm-export-__sync_icache_dcache-for-xen-privcmd.patch
        - bugfix/powerpc/powerpc-lib-makefile-don-t-pull-in-quad.o-for-32-bit.patch
        - bugfix/all/
          radeon-amdgpu-firmware-is-required-for-drm-and-kms-on-r600-onward.patch
        - bugfix/all/disable-some-marvell-phys.patch
        - debian/overlayfs-permit-mounts-in-userns.patch
        - bugfix/all/tools-perf-remove-shebangs.patch
        - debian/ntfs-mark-it-as-broken.patch
        - features/all/db-mok-keyring/
          0003-MODSIGN-checking-the-blacklisted-hash-before-loading-a-kernel-module.patch
        - features/all/db-mok-keyring/
          0004-MODSIGN-Import-certificates-from-UEFI-Secure-Boot.patch
        - debian/android-enable-building-ashmem-and-binder-as-modules.patch
        - features/all/aufs5/aufs5-mmap.patch
        - features/all/aufs5/aufs5-standalone.patch
        - features/all/lockdown/
          0029-efi-Lock-down-the-kernel-if-booted-in-secure-boot-mo.patch
      * Enable coreboot memconsole (Closes: #872069)
      * [rt] Update to 5.2-rt1
    
      [ Karsten Merker ]
      * [riscv64] Change the kernel image format from ELF to flat Image.
        (Closes: #928451)
      * [riscv64] Update config and image format (Closes: #933603):
        - Enable SiFive UART and UART console support
        - Enable clock drivers for the SiFive FU540
        - Backport kernel image header support from kernel 5.3
    
      [ Uwe Kleine-König ]
      * [armhf] Add support for all i.MX6 variants.
      * enable XFRM_STATISTICS (Closes: #929938)
      * [arm64] Add support for Raspberry Pi 3 camera host interface (Closes:
        #933228)
      * Enable CRYPTO_ZSTD for ZRAM with ZSTD compression (Closes: #932722)
    
      [ Lubomir Rintel ]
      * [armhf] Enable config items for OLPC XO-1.75 (Closes: #927791)
    
    linux (5.0.2-1~exp1) experimental; urgency=medium
    
      * New upstream stable update:
        https://www.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.0.2
    
      [ Vagrant Cascadian ]
      * [arm64,armhf] Enable PHY_ROCKCHIP_INNO_HDMI as modules.
    
      [ Ben Hutchings ]
      * [amd64] kexec: Enable KEXEC_SIG, replacing KEXEC_VERIFY_SIG
      * [armel] MTD: Enable MTD_PHYSMAP as module and set MTD_PHYSMAP_OF=y
        - udeb: Include physmap instead of physmap_of in mtd-modules (fixes FTBFS)
      * [armhf] sound/soc/ti: Enable SND_SOC_DAVINCI_MCASP, SND_SOC_NOKIA_RX51,
        SND_SOC_OMAP3_PANDORA, SND_SOC_OMAP3_TWL4030, SND_SOC_OMAP_ABE_TWL6040
        as modules; replacing SND_DAVINCI_SOC_MCASP, SND_OMAP_SOC_RX51,
        SND_OMAP_SOC_OMAP3_PANDORA, SND_OMAP_SOC_OMAP_TWL4030,
        SND_OMAP_SOC_OMAP_ABE_TWL6040 respectively
      * udeb: Add thermal_sys to kernel-image (fixes FTBFS on mips*, ppc64*,
        riscv64)
      * [powerpc*] mm: Only define MAX_PHYSMEM_BITS in SPARSEMEM configurations
        (fixes FTBFS on powerpc, powerpcspe)
      * debian/source/lintian-overrides: Override license-problem-gfdl-invariants
        in more files
      * debian/rules: Remove debian/*.substvars in clean target
      * debian/source/lintian-overrides: Override
        orig-tarball-missing-upstream-signature
    
    linux (5.0.1-1~exp1) experimental; urgency=medium
    
      * New upstream release: https://kernelnewbies.org/Linux_5.0
      * New upstream stable update:
        https://www.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.0.1
    
      [ YunQiang Su ]
      * [mipsel, mips64el] Enable DRM_AST and FB_SM750 for loongson-3
        install ast and sm750fb to loongson-3's fb-modules
      * [mips r6] Disable JUMP_LABEL for now: it will cause Reserved Instruction.
        Enable SERIAL_OF_PLATFORM, if not, userland shows nothing.
        Enable CPU_HAS_MSA, HIGHMEM, CRYPTO_CRC32_MIPS, and NR_CPUS to 16.
        Support some boston drivers: IMG_ASCII_LCD, I2C_EG20T, PCH_PHUB, MMC,
          PCIE_XILINX, RTC_DRV_M41T80, SPI_TOPCLIFF_PCH.
    
      [ Hideki Yamane ]
      * [x86] Enable Touchpad support on Gemini Lake (Closes: #917388)
    
      [ Helge Deller ]
      * [hppa] Build only 32- and 64-bit SMP-kernel: Alternative
        live-patching code will patch kernel for UP at boot if necessary.
    
      [ Romain Perier ]
      * Refreshed debian/export-symbols-needed-by-android-drivers.patch to export
        __close_fd_get_file() and task_work_add(), both required by binder.
      * Refreshed debian/revert-objtool-fix-config_stack_validation-y-warning.patch,
        so this can be applied against 4.20.4
      * Refreshed patch for lockdown
        0028-efi-Add-an-EFI_SECURE_BOOT-flag-to-indicate-secure-b.patch, so this
        can be applied against >= 4.20.13
    
      [ Marcin Juszkiewicz ]
      * udeb: Add virtio-gpu into d-i to get graphical output in VM instances.
    
      [ Ben Hutchings ]
      * SCSI: Enable SCSI_MYRB, SCSI_MYRS as modules, replacing BLK_DEV_DAC960
      * [arm64] remoteproc: Enable QCOM_Q6V5_MSS, renamed version of
        QCOM_Q6V5_PIL
      * [x86] drivers/gpu/drm/amd: Re-enable HSA_AMD (Closes: #920454)
      * genpatch-aufs: Update to use aufs5-standalone
      * aufs: Update support patchset to aufs5.0 20190311
      * lockdown: Update patchset to 2019-02-18 version
    
    linux (4.20-1~exp1) experimental; urgency=medium
    
      * New upstream release: https://kernelnewbies.org/Linux_4.20
    
      [ Ben Hutchings ]
      * aufs: Update support patchset to aufs4.x-rcN 20181217
      * [rt] Disable until it is updated for 4.20 or later
      * [x86] udeb: Move rfkill to new rfkill-modules package to avoid duplication
      * debian/source/lintian-overrides: Update overrides for GFDL notices
    e20cba76