Commit af2c5a42 authored by Lorenzo "Palinuro" Faletra's avatar Lorenzo "Palinuro" Faletra
Browse files

Import Debian version 5.0.7

parrot-core (5.0.7) lts-updates; urgency=medium
.
  * Add parrot-upgrade.
  * Add apt wrapper.
parent df3a5c6e
Pipeline #5030 failed with stages
#!/bin/bash
set -e
DEBIAN_FRONTEND="noninteractive"
DEBIAN_PRIORITY="critical"
DEBCONF_NOWARNINGS="yes"
export DEBIAN_FRONTEND DEBIAN_PRIORITY DEBCONF_NOWARNINGS
apt update || echo failed to update index lists
dpkg --configure -a || echo failed to fix interrupted upgrades
apt --fix-broken --fix-missing install || echo failed to fix conflicts
apt -y --allow-downgrades --fix-broken --fix-missing dist-upgrade
parrot-core (5.0.7) lts-updates; urgency=medium
* Add parrot-upgrade.
* Add apt wrapper.
-- Lorenzo "Palinuro" Faletra <palinuro@parrotsec.org> Fri, 07 Jan 2022 13:18:08 +0100
parrot-core (5.0.6) lts-update; urgency=medium
* Update repo config.
......
......@@ -6,5 +6,6 @@ profile.d/* etc/profile.d/
udev-rules/* etc/udev/rules.d/
Xsession.d/* etc/X11/Xsession.d/
bin/* usr/bin/
localbin/* usr/local/bin/
dconf usr/lib/parrot-skel/etc/
skel usr/lib/parrot-skel/etc/
#!/bin/bash
case $1 in
upgrade)
echo -e "
APT on Parrot behaves differently than Debian.
apt upgrade is equivalent to apt full-upgrade in Debian,
and performs a complete system update.
Use apt safe-upgrade to perform a partial upgrade.
"
/usr/bin/apt full-upgrade
;;
safe-upgrade)
/usr/bin/apt upgrade
;;
dup)
/usr/bin/apt dist-upgrade
exit
;;
u|up)
/usr/bin/apt update
exit
;;
i|in)
/usr/bin/apt install ${@:2}
exit
;;
r|rm)
/usr/bin/apt remove ${@:2}
exit
;;
list-updates|lu|l)
/usr/bin/apt list --upgradable
exit
;;
s|se)
/usr/bin/apt search ${@:2}
exit
;;
p|po|pol)
/usr/bin/apt policy ${@:2}
exit
;;
sh)
/usr/bin/apt show ${@:2}
exit
;;
esac
/usr/bin/apt $@
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment